Electronic Spreadsheet

(Advanced)

( Fastracl« Revision )

» Data Consolidation: It allows you to gather together your
data from separate worksheets into a master warksheet.
In other words, the Data Consolidation Function takes data
From a series of worksheets and summaries it into a single
worksheet.

> Steps for Data Consolidation are:

» Openthe worksheet that contains the cell ranges to
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be Consolidated.
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Choose the Consolidate option under the Data
menu.
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Select source Data range and click Add. The selected
range now appears on the Consolidation ranges list.

Select additional ranges and click Add after each
selection.

Specify where you want to display the result by
selecting a target range from the Copy results to
box.

Select a Function from the Function list. The Sum
function is the default setting.
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» Select either Row labels or Column labels. The text
in the labels must be identical in all the specified
source range.

» Click OK to Consolidate the ranges.

» Creating Subtotals: SUBTOTAL, totals/adds data
arranged in an array—that is, a group of cells with labels
for columns and/or rows. Using the Subtotals dialog, you
can select arrays, and then choose a statistical function to
apply to them. It is accessible from Data menu.

» Steps to Insert Subtotal Values Into a Sheet:
» Ensure that the columns have labels.

» In the Subtotals dialog, in the Group by box, select
the column that you want to add the subtotals to.

» Inthe Calculate subtotals for box, select the columns
that you want to subtotal.

» In the Use Function box, select the function.
» (Click OK.

» Using “What IF" Scenarios: Scenarios are a tool to test
“what-if” questions. Each scenario is named, and can be
edited and Formatted separately. You can easily switch
between different scenarios by using the Navigator. For
example, if you wanted to calculate the effect of different
interest rates on an investment, you could add a scenario
For each interest rate, and quickly view the results.

» Creating Scenarios:

» Select the cells that contain the values that will
change between scenarios.

» Choose Tools > Scenarios.

» On the Create Scenario dlalog, enter a name for
the new scenario. This name is displayed in the
Navigator and on the title bar of the scenario.
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» Optionally add some information to the Comment
box.
» Optionally select or deselect the options in the
Settings section.
» Click OK to close the dialag.
Goal Seek: Usually, you run a Formula to calculate a
result based upon existing values. By contrast Goal Seek
option under Tools menu, helps to find values which will
produce the result that you want. For example, Chief
Financlal Officer has a good Idea of the company's income
In the First three quarters, because of the contracts that
are already slgned. For the Fourth quarter, however,
no definite income is avallable. So how much must the
company earn in Q4 to reach its goal? Then Chief Financlal
Officer runs a goal seek on the empty cell For Q4 sales and
recelves the answer.

Solver: Solver option under Tools menu amounts to a
more elaborate form of Goal Seek. The difference is that
the Solver deals with equations with multiple unknown
variables. It is specifically designed to minimize or
maximize the result according to a set of rules that you
define.

Link Data and Spreadsheets Using Multiple Workbooks
and Linking Cells: Spreadsheet allows you to link the cells
From various worksheets to summarize data from several
sources. In this manner, you can create formulas using a
combination of local and linked information. Multiple
sheets help to keep the information organised.

Inserting New Sheets: Whenyouopenanewspreadsheet,
by default, it has a sheet named Sheet1. There are several
ways to insert a new sheet. The First step, in all cases, Is to
select the sheet that will be next to the new sheet. Then
do any of the following:

» Select Insert > Sheet from the menu bar, or
» Right-click on the tab and select Insert Sheet, or

» Click in an empty space at the end of the line of
sheet tabs.

“Each method opens the Insert Sheet dialog box where
you can choose to put the new sheet before or after the
selected sheet and how many sheets to insert.”

Renaming Sheets: There are three ways you can rename a
worksheet. You can do any of the following:

» Double<click on one of the existing worksheet
names.

» Right-click on an existing worksheet name, then
choose Rename fram the resulting Context menu.

» Select the worksheet you want to rename (click on
the worksheet tab) and then select the Sheet option
from the Format menu. This displays a submenu
From which you should select the Rename option.

Cell Reference: A cell reference refers to a cell or a range
of cells on a worksheet that can be used in a formula to
calculate values.

Referencing Other Sheets: There are two ways to
reference cells in other sheets:
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» Byentering the Formula directly using the keyboard:
e Typing the reference is simple once you know
the format the reference takes. The reference
has three parts to it: Path and file name,
Sheet name, Cell name.
e Thegeneral fFormat for the reference Is ='file:///
Path &File Name'#5SheetName.CellName
» By using the mouse.

» Hyperlinks: Hyperlinks can be used in Calc to jump to a

different location Ffrom within a spreadsheet to other
parts of the same File or to different Files or even to
websites. Hyperlinks can be stored within your file as
elther relative or absolute.
An absolute link will stop working only if the target Is
moved. A relatlve link will stop working only if the start
and target locatlons change relative to each other. For
instance, if you have two spreadsheets in the same Folder
linked to each other and you move the entire folder to a
new location, a relative hyperlink will not break.
Insert and Modify Links Using the Hyperlink Dialog:
To display the dialog, click the Hyperlink icon on the
Standard toolbar or choose Insert > Hyperlink from the
menu bar.
Linking To External Data: Youcaninserttables from HTML
documents, and data located within named ranges from
an OpenOffice.org Calc or Microsoft Excel spreadsheet,
into a Calc spreadsheet you can do this in two ways: using
the External Data dialog or using the Navigator.
Using the External Data Dialog: Steps are:
» Open the Calc worksheet where the external data is
to be inserted. This is the target worksheet.
» Select the cell where the upper left-hand cell of the
external data is to be inserted.
» Choose Insert -> Link to External Data.
» On the External Data dialog, type the URL of the
source worksheet.
» In the Available tables/range list, select the named
ranges or tables you want to Insert.
» Click OK to close this dialog and insert the linked
data.
Linking to Registered Data Sources: You can access 3
variety of databases and other data sources and link them
into Calc worksheets. First you need to register the data
source with OpenOFfice.org. To register a data source
that is in *.odb format:
» Choose Tools —> Options —> OpenOffice.org Base —>
Databases.
» Click the New button to open the Create Database
Link dialog.
» Enterthe location of the database file, or click Browser
to open a file browser and select the database file.
» Type a name to use as the registered name for the
database and click OK.

» Sharing Worksheet Data: Spreadsheet software allows

the user to share the workbook and place it in the network
location where several users can access it simultaneously.
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This Is required to either speed up data entry or simply
make things easier for collaboration purposes.

Setting up a Spreadsheet Ffor Sharing: Open the
spreadsheet document, choose Tools > Share Document
to activate the collaboration fFeatures For this worksheet.
A dialog opens where you can choose to enable or disable
sharing.

To enable sharing, select the box at the top of the dialog,
and then click OK. A message appears stating that you
must save the worksheet to activate shared mode. Click
Yes to continue. The word (shared) is then shown on the
title bar after the worksheets title.

Saving a Shared Spreadsheet: When you save a shared
spreadsheet, one of several situations may occur:

» |If the worksheet was not modified and saved by
another user since you opened It, the worksheet Is
saved.

» |fFthe worksheet was modified and saved by another
user since you opened it, one of the following
events will occur:

e Ifthe changes do not conflict, the warksheet is
saved, the dialog below appears, and any cells
modified by the other user are shown with a red
baorder.

e If the changes conflict, the Resolve Conflicts
dialog is shown. You must decide for each
conflict which verslon to keep, yours or the
other person’s. When all conflicts are resolved,
the worksheet is saved.

e |IF another user is trying to save the shared
waorksheet and resolve conflicts, you see a
message that the shared spreadsheet File is
locked due to a merge-in in progress.

» Most spreadsheets software automatically turns off some
features in shared workbooks to simplify the workbook
since multiple people can be working on the file at
the same time. For example, shared workbooks don't
allow merging cells, conditional fFormatting, or inserting
pictures/graphs/etc.

Record Changes: Calc has the feature to track what data
was changed, when the change was made, who made
the change and in which cell the change has occurred.
For example, if you are the sponsor of a youth baseball
team. The coach has submitted a budget to you and you
are concerned that the coach won't see the changes you
made, so you decided to use Calc with the record changes
Feature turned on, so that the coach can easlly see the
changes you have made.

How to Turn on Record Changes Feature ON:

» Open the Shared Spreadsheet.

» Select Edit > Changes > Record from the menu bar.

» Begin editing the worksheet.

A red colored border, with a dot in the upper left-hand
corner, appears around a cell where changes were made.
Viewing Changes: Calc allows you to control what
changes you see when reviewing a worksheet. To change
the avallable Flters, select Edit > Changes > Show You can
Filter based on:

» Date: Only changes made in a certain time range are
displayed.

» Author: Only changes made by a specific author are
displayed.

> Range: Only changes made in a specific range of
cells are displayed.

» Comment: Searches the content of the comments
and only displays changes which have comments.

» Show Accepted Changes: Only changes you accepted
are displayed.

> Show Rejected Changes: Only changes you rejected
are displayed.

» Adding Comment to a Change:

» Make the change to the spreadsheet.
» Select the cell with the change.

» Choose Edit > Changes > Comments.
> Type your own comment and click OK.

» Editing Comment:

» Select the cell with the comment that you want to
edit.

» Select Edit > Changes > Comments.

» Edit the comment and click OK.

» Accepting or Rejecting Changes: When you recelve a

worksheet back with changes. Now, as the original author,
you can step through each change and decide which
change to accept and which one to reject. To begin this
process:
> Open the edited worksheet.
» Select Edit > Changes > Accept or Reject.
» Calc steps through the changes one at a time. You
can choose to accept or reject each change.
Merging Worksheets: Sometimes, multiple reviewers
return edited versions of a worksheet at the same time. In
this case, Calc provides the feature of merging worksheets:
» Open the original worksheet.
» Select Edit > Changes > Merge Document.
> A file selection dialog opens. Select a file you want
to merge and click OK.
» Accept or Reject Changes dialog opens and you can
accept ar reject the changes.
Comparing Documents: When sharing worksheets
reviewers may forget to record the changes they make.
Calc can find the changes by comparing worksheets.
In order to compare worksheets you need to have the
original worksheet and the one that is edited. To compare
them:
» Open the edited worksheet that you want to
compare.
» Select Edit > Compare Document.
> An open worksheet dialog appears. Select the
original worksheet and click Insert.
» Calc Finds and marks the changes.
Macro: A macro is a saved sequence of commands or
keystrokes that are stored For later use. Macros are
especially useful to repeat a task the same way over and
over again.
Using the Macro Recorder: Use Tools > Macros > Record
Macro to start the macro recorder. The Record Macro
dialog is displayed with a stop recarding button. Click Stop
Recording to stop the macro recorder.

» Advantages of Using Macro in Calc:

>» Macros automates the repetitive and routine tasks.
> Macros speed up your process and reduce time.
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& Practice Exercise

'@ Multiple Choice Questions N

Q1. Which of the following type of package does Calc

refer to?

a. Spreadsheet b. Multi sheet

c. Double sheet d. Cannot be determined

Which of the following applications is not suitable

for Calc?

a. Balance sheet preparation

b. Result analysls

C. Presenting an idea about a product

d. All of the above

Which of the following is the extension of a

worksheet created in Calc?

a. .ods b..odd C..xls d..obj

Which of the following will be inserted in a worksheet

if =starcalcteam() is inserted in a Calc cell?

a. Stars

b. Photograph of Calc developer team

¢ Calc license information

d. Calc version information

How can one calculate total of values entered in a

worksheet in a Calc document?

a. By manual entry b. By AutaSum

c. By formula d. All of these

If we move a cell containing a formula having

reference to another cell in the worksheet, what will

happen to the cell numbers used in formula?

a. The cell row and columns are changed at destination

b. The cell row numbers are changed at destination.

c. The cell column numbers are changed at destination

d. Nothing will be changed.

Which option is uses to open Calc program?

a. Applications -= Office -= OpenOffice.org Spreadsheet

b. Applications -> OpenOffice -> OpenOffice.org
Spreadsheet

c. Start -> Office -> OpenOffice.arg Spreadsheet

d. Start -> OpenQOffice -> OpenQOffice.org Spreadsheet

Which type of package is Calc?

a. Word processor b. Spreadsheet

Q2.

Q3.

Q4.

Q5S.

Q6.

Q7.

Q8.

c. Database d. Presentation

Q9. In Calc, how many spreadsheets are there by default?
a. 2 b.3 C.4 d.5

Q 10. How many worksheets are available in spreadsheet
document?
a. 24 b. 64 c. 256 d. 65536

Q 1. How many menu are available in Calc?
a. b6 b.7 c.8 d.9

Q 12. Which sign is available on bottom right side of the
active cell?
a. + b. # C.— d. o

Q 13. How many rows are there in Calc?
a. 65516 b.65526 . 1to 65536 d. 65546
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Q14.

Q15.

Q 16.

Q17.

Q 18.

Q19.

Q 20.

Q2L

Q 22.

Q23

Q24.

Q 25.

Q 26.

Q27

How many columns are there in Calc?

a. 226 b. 236 C. 246 d. 256
Which is the basic element of a spreadsheet?
a. Cell b. Worksheet

c. Workboaok d. Row and Column

In which form scroll bar is seen in Calc?

a. Horizontal b. Vertical

c. Both a. and b. d. None of these

Which background does current worksheet tab name
have?

a. Black b. White c. Red
To add or remove toolbar, which option is used?

a. File -= Toolbars b. Insert -> Toolbars

c. Vlew -> Toalbars d. Format -= Toolbars
Which menu-option is sued to rename a worksheet?
a. Format -> Sheet -> Rename

b. Format -> Sheet -> Madify

C. Edit -= Sheet -= Rename

d. Edit -> Sheet -> Madify

Which menu-option is used in Calc to add new
worksheet?

a. File -> Sheet b. View -= Sheet

c Insert -> Sheet d. Tools -> Sheet

Which menu-option Is used to save worksheet in
Calc?

a. File -= Save

d. Green

b. File -= Store

c. Flle -= Add d. Flle -= Set
Which symbol is used for multiplication in Calc?
a. & b. @ C# d @

Which symbol is necessary to write at the starting of
formula?
a. = b. # C@ d e

Which key is pressed to see the result after entering
formula in Calc?

a. Insert key b. Ctrl key

C. Enter key d. Shift key

To show cell range in Calc which symbol is used
to separate the first cell address and the last cell
address?

a. . ... o d.:

Which of the following option is used to add the
values between cell Al to A5 in Calc?

a. = Al+A2+A3+A4+A5 b. = Sum(ATA5)

C Z button d. All of these

A colored border, with .............. , appears around a

cell where changes are made in a shared worksheet.
[CBSE 2023]

a. a dot in the upper left-hand corner

b. a dot in the lower left-hand corner

C across In the upper left hand corner
d. a cross in the upper right-hand corner
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Q 28. In which form, the sum function appears in function

bar?

a.z b. A o d w

On which bar X~ symbol does appear?

a. Title bar b. Formula bar

c. Symbol bar d. Format bar

What is called to arrange data in order?

a. Filtering b.Inserting c. Sorting d. Deleting

Arguments passed to a macro from Calc are

[CBSESQP 2021, Term-1]
a. strings b. numbers
c. references d. values

Q32. ............ function takes data from a series of
worksheets or workbooks and summaries it into a
single worksheet that you can update easily.

[CBSESQP 2021, Term-1]

a. Summation b. Data consolidation
c. Data format d. Data Chart
If you are continually working with the same range,
then you may give a name to the range using ..........
option under Data Menu. [CBSE SQP 2021, Term-1]
a. define data b. define range
c. define reference d. define address
In Calc, using the Subtotals dialog, you can select
arrays and then choose a statistical function to apply
to them. For efficiency, you can choose up to...........
array to which to apply a function.
[CBSESQP 2021, Tarm-1]
a. two b. three c. four d. five
Solve option under Tools menu amounts to a more
elaborate form of ................ . The difference is that
the Solver deals with equations with multiple...........
[CBSESQP 2021, Term-1]
a. unknown variables, goals seek
b. goals seek. unknown varlables
C. variables, equation
d. subtotal goal seek
Usually, you run a formula to calculate a result based
upon existing values. By contrast, using, you can
discover what values will produce the result that you
want? [CBSESQP 2021, Tarm-1]
a. Subtotal b.Sort Lists c. Scenario d. Goal Seek

Rama and two of her friends are doing survey of
gender wise employment rates of their locality as
a school project using spreadsheet. They all want
to work simultaneously to complete it on time.
What option they should use to access the same
Spreadsheet to speed up their work?

[CBSE SQP 2021, Term-1]
b. Shared Warksheet
d. Lock Worksheet

Q 29.

Q 30.

Q 3l

Q 33.

Q 34.

Q 35.

Q 36.

Q37.

a. Consolldate Waorksheet
c. Link Worksheet

038 Acuaae refers to a cell or a range of cells on a
worksheet whose data values can be used in a
formula. [CBSE2023]
a. sheet b. cell

c. cell reference d. cell data
Q 39. In Calc, to create the reference with the mouse:
[CBSESQP 2021, Term-1]

a. Both Spreadsheets need not be open

b. Select the cell in which the formula is going to be
entered
c. There Is no need of symbol
d. Cell reference is not required
Q 40. Macros option is available in OpenOffice (00) Calc,
in which tab:

a. Insert b. Tools c. Data d. Format

Q 41 In Data Consolidate what are the operations we can
perform ......cccveenen
a. sum b. average
C. max d. All of these

Q42. ........... feature adds data arranged in a group of
cell in Calc, with labels for columns and/or rows.

[CBSE 2023]

a. Average b. Subtotal
c Goal seek d. Solver

Q43. .............. feature of Calc is used to test ‘what-if
questions. [CBSE 2023]
a. Solver b. Goal seek
C. Scenario d. Styles

Q4. ............... feature of Calc helps to track what data

was changed, when the change was made, who
made the change and in which cell the change has

occurred. [CBSE 2023]
a. Recard Changes b. Edit recard
c. Change record d. Macro

Q 45. Goal Seek command is found in..............

a. data b. tools c. format d edit
Q 46. Shortcut to Navigator is ........cccceceveeiiiinnaes
a. F10 b.FB c.F6 d. F5
Q 47. The Record Macro option is present under ................
menu.
a. toals b. data c. format d. insert
Q 48. Which tool you can use in Calc to make an estimate

of output values for different input values?
I. Multiple Operations ii.Macros
iii. Scenarios Iv. Goal Seek
a. Only (i) and (iii) b. Only (i) and (iv)
c (i). (i) and (iv) d. All of these
Q 49. In spreadsheet, to apply Goal Seek your cell pointer
must be in:
a. the changing cell whose value you need to find.
b. the result cell where formula Is entered
c the cell where your targeted value Is entered
d. None of the above

Q 50. Which of the following tools deals with multiple

unknown values?
a. Goal Seek b. Scenario
c. Solver d. Data Table

Q 5L In OO Calc, which option should be used to accept/
reject the changes in the shared sheet?
a. Edit->Accept
b. Edit — Changes — Record
c. Edit —» Changes —» Show
d. edit — Changes-Accept/Reject
Q 52. In a spreadsheet, absolute reference will be referred

to:
a. SAS4 b.SA4 c. AS4 d. A4
m @) www.studentbro.in



Q 53.

Q 54.

Q55.

Q S6.

Q 57.

Q 58.

Q 59.

Q 60.

Q 6L

Q 62.

Q 63.

Ramesh wants to solve one variable problem.
Suggest him which of the data analysis tools is best
suited for him?

a. Solver b. Goal Seek

C. Scenario d. Data Table

Shovit wants to combine and find the sum/average
of marks obtained by the students in the previous
three periodic tests. The data is stored in various
sheets of a workbook. Which of the following tools
is best suited for him?

a. Data Range b. Data Consolidation

c. Data Review d. Data Merge

Rakesh wants to apply a formula in the entire
column of the spreadsheet,with respect to only one
cell. What referencing he will use to get the correct
result?

a. Relative Referencing b. Absolute Referencing

c. Mixed Referencing  d. Hyperlink

Which function cannot be performed through
Subtotal in a spreadsheet?  [CBSESQP 2021, Term-1]

a. Sum b. Product

C. Average d. Percentage

Scenarios are a tool to test .................. questions.
a. auto b. goal Seek

c. what-if d. drop down

It refers to a cell or a range of cells on a worksheet
and can be used to find the values or data that you

want formula to calculate. [CBSESQP 2021, Term-1]
a. row b. column
C. autosum d. cell reference

.................. , totals/adds data arranged in an array—
that is, a group of cells with labels for columns and/
or rows, which step one must should follow before

using the Subtotal option?  [CBSESQP 2021, Term-1]
a. Consolidate b. Rename Data
c. Filter Data d. Subtotal

Which of the following is more elaborate form of

Goal Seek? [CBSESQP 2021, Term-1]
a. Subtotal b. Scenario
c. Solver d. Cansolidate

.................. means combining data in a spreadsheet

from different worksheets into master worksheet.
[CBSESQP 2021, Term-1]

a. Hyperlinks b. Consaolidating

c. Linking d. Filter

An link will stop working only if the

target is moved while a link will stop

working only if the start and target locations change

relative to each other. [CBSE SQP 2021, Term-1]

a. absolute, fixed b. relative, absolute

c. absolute, relative  d. permanent. absolute

By default, sheets tab are present at the...................
of the spreadsheet. [CBSESQP 2021, Term-1]

a. top b. bottom  c. center d. right
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Q 64.

Q 65.

Q 66.

Q 67.

Q 68.

Q 69.

Q70.

Q7L

Q72

The cell reference in a spreadsheet for cell range B2

O ELS I8 v . [CBSESQP 2021, Term-1]
a. B2F15 b.B2:F15

c. B2F15 d. B2-F15
A...............hyperlink contains the full address of the
destination file or web page. [CBSESQP 2021, Term-1]
a. relative b. absolute

C. mixed d. address

Macros are especially useful to ............... the same
way over and cover again. [CBSE 2023]

a. repeat a task b. reject a task

C report a task d. comment a task

Sunita is making a project in spreadsheets. Her friend

has told her how to rename a spreadsheet as it will

help her identify the worksheet data easily. She was

very excited and told the same to her brother. Her

brother told her that in spreadsheets (OpenOffice),

a worksheet can be renamed using.........c.coee... ways.
[CBSE SQP 2021, Term-1]

a.2 b.3 C4 d.1

Raj has created a worksheet where he has added all

the information of his employees. He wants every

employee to go through the worksheet and update

their address and phone number, if required. He

also would like to know the changes done by his

employees. Which feature of spreadsheet he should

enable to see the changes made by his employees?
[CBSESQP 2021, Term-1]

a. Macro b. Link Workbook

c. Change Worksheet d. Track Changes

Sravan wants to do the same set of tasks to be done

repeatedly like formatting or applying a similar

formula in a similar range of data. Suggest him a

suitable tool for that.

a. goal seek b.solver C. scenario

What is the shortcut key for row hide?

a.Ctrl +9 b. Ctrl + FS

C. Shift + FS d. Ctrl + shift + 9

............... can be used in Calc to jump to a different

location from within a spreadsheet and can lead to

other parts of the current file, to different files or

even to websites. [CBSESQP 2021, Term-1]

a. Tables b. Auto Sum

c. Goal Seek d. Hyperlinks

Statement |: The data from the consolidation ranges

and target range are saved when you save the

warksheet.

Statement |l: If you later open a worksheet in which

consolidation has been defined, this data will not be

available again.

Consider above two statements, identify the correct

one. [CBSESQpP 2021, Term-1]

a. Statement | is wrong,

b. Statement Il Is wrong,

c Both the Statements | and Il are wrong.

d. Both the Statements | and Il are correct.

d. macros
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Q73.

Q74.

In Spreadsheets,

Statement |: To consolidate by row labels or column
labels, the label must be contained in the selected
sources ranges.

Statement Il: The text in the labels must be identical
so that rows or columns can be accurately matched.
Statement lll: If the row or column label does not
match any that exist in the target range, it will be
appended as a new row or column.

Consider above two statements, identify the correct
one. [CBSESQP 2021, Term-1]
a. Only Statement | and Il are correct.

b. Only Statement Il is correct

c. Only Statements Il and Ill are correct

d. All the Statements are correct.

Rohan has 50,000 that he wants to invest in two
mutual funds for one year. Fund A is a low risk
fund with 18% interest rate and Fund B is a higher
risk fund with 21% interest rate. Which feature of
spreadsheets (Calc) will help him to decide?

a. Solver b. Subtotal

c. Linking sheets d. Macros

-§) Fill in the Blanks Type Questions N

Q75. An application that can be used to organised

Q76.

Q77.

numerical data in the form table and perform
calculationsonitcalleda........ccceunen..... application.
i | 5 - SO — is a fundamental element of
a worksheet.

A workbook is a collection of ......cccceeeerrnnnnen

K7 I | AP, cell format displays the content

Q79.

Q 80. The....

of cell in exponential notation.

In OpenOffice Calc, the.................... feature is used
to fill a series of numbers such as 2,4,6,8 and so on.
eeneeenneeo. diSplays the name of the active cell.

2 1 | S ——— contains the Name Box and the

Q 8z2.

Input Line textbox.
By default, in Calc, the numbers are aligned to the
........................... within a cell.

‘Q Assertion & Reason type Questions N

Directions (Q. Nos. 83-90): /n the questions given
below, there are two statements marked as Assertion
(A) and Reason (R). Read the statements and choose the
correct option.
a. Both Assertion (A) and Reason (R) are true and
Reason (R) is the correct explanation of Assertion (A).
b. Both Assertion (A) and Reason (R) are true, but
Reason (R) is not correct explanation of Assertion (A).
c. Assertion (A) Is true, but Reason (R) Is false.

d. Assertion (A) is false, but Reason (R) is true.

Q 83. Assertion (A): Macro does not help in saving time
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in cases when a same set of tasks are to be done
repeatedly.

Reason (R): Macros are stored in the same
workbook in which they are created.

Q 84.

Q 85.

Q 86.

Q 87.

Q 88.

Q 89.

Q 90.

Assertion (A): The variable cells are the cells that
contain variable data that can be changed to
achieve the objective.

Reason (R): We can refer to cell that are on other
worksheets, in the same workbook, by prepending
the name of the worksheet followed by a dollar
sign ($) before the cell address.

Assertion (A): A cell reference refers to a cell or a
range of cells on a worksheet and can be used to
find the values or data that we want to calculate.
Reason (R): The Subtotal option is present on the
Reference tab.

Assertion (A): The solver add-in is similar to Goal-
seek, but it can accommodate more variables.
Reason (R): Count Function counts the cells that
contains numbers.

Assertion (A): A Scenario Manager can have multiple
variables, but it can only accommodate up to 32
values.

Reason (R): We can add the Solver from the Data tab.
Assertion (A): Subtotal creates a hierarchy of
groups, known as an outline.

Reason (R): The last number displays both subtotals
and individual values in the outline symbol
Assertion (A): Autosum automatically selects the
values around the cells either rows or column.
Reason (R): The primary purpose of solver is
simulation and optimisation of various business
and engineering models.

Assertion (A):The data consolidation function takes
data from a series of worksheets or workbooks and
summaries it into a single worksheet that can be
updated easily.

Reason (R): The Sort option is present on the data

tab.

Answers °
1.(a) 2. (c) 3. (3) 4. (b) 5. (d)
6. (a) 7. (a) 8. (b) 9. (b) 10. (¢)
11. (d) 12. (3a) 13. (€) 14. (d) 15. (a)
16. () 17. (b) 18. (c) 19. (a) 20. ()
21. (a) 22. (b) 23. (3) 24, (¢) 25. {€)
26. (d) 27. (a) 28. (a) 29. (b) 30. ()
31.(d) 32. (b) 33.(b) 34. (b) 35. (0
36. (d) 37. (b) 38.(c) 39. (3) 40. (b)
41. (d) 42. (b) 43. (c) 44. (a) 45. (b)
46. (d) 47. (a) 48.(d) 49. (b) 50. (c)
51. (d) 52. (8) 53.(b) 54. (b) 55. (b)
56. (d) 5. (€] 58. (d) 59. (d) 60. (c)
61. (b) 62. (c) 63.(b) 64. (c) 65. (b)
66. (a) 67. (b) 68.(d) 69. (d) 70. (a)
71. (d) 72. (b) 73.(d) 74. (2)
75. spreadsheet76. cell
77. worksheet 78. scientific
79. autofill 80. name box
81. Formula Bar82. right
83. (d) 84. (c) 85.(c) 86. (0 87. (c)
88. (b) 89. (b) 90. (b)
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4) Case Study Based Tupe Questions N

Case Study 1

What-If Scenario: It is the process of calculating
backwards to find out an input by providing
a specific output. It can be considered as the
opposite to formulaec. We use formulae to
calculate an output by providing inputs, whereas
What-If analysis helps us find out what input
will result in a specific output. By using What-If
Scenario tools, we can use several different sets
of values in one or more formulae to explore all
the various results. We can use What-If Scenario
tools to estimate our monthly savings that meet
our retirement goals, find the return rate of an
investment, plan our budget and so on.

Q L Study the figure below. After doing her budget,
Lucy realises that she cannot pay more than
$3,850 per month (Monthly Payment) towards
a new apartment. Which analytical function
could she utilise to calculate her new loan
amount based on the figure below?

A ] B | C [ D
1
: APARTMENT LOAN
a MONTHLY PAYMENT (PMT): -5512.02
5 | MONTHLY INTEREST RATE (RATE): 2.00%
6 | MONTHS TO PAY OFF LOAN (NPER): 120
7 | AMOUNT TO LOAN FROM BANK (PV): | 250000

a. She could use the Solver function.
b. She could use the What-If Scenario function.

c. She could use the Goal Seek function.
d. She could use the Data Table function.

Q 2. Adam is searching for the Solver function, but
cannot find it anywhere, not even under the
Data tab on the Ribbon. Where could he find it?

a. Tools b. Data c. Format d. Insert

Q 3. Study the figure below. After working out her
budget, Casey realises that her expenses at
$3,960 are far above her income of $2850.She
wants to modify her budget by reducing all her
non-essential budget items. Which analytical
tool could she use to achieve this?

R

" | CASEY'S MONTHLY BUDGET
2 |RENT 1100
3 |GAS 250
4 [POWER 85
S |WATER 27
6 |CABLE 138
7 |CAR INSTALLMENT 457
g8 |INSURANCE 98
9 |GROCERIES g54
10 [TOILETRIES 358
11 [ENTERTAINMENT 150
12 |CINEMA 90
13 |[EATING OUT/TAKE OUT 250
14 |GYM/CLUB MEMBERHIP 110
s E
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a. Goal Seek will allow her to change her total
expenses by modifying all the cells she
specifies which contain non-essential items.

b. Data tables will allow her to change all the
amounts to fit in with her income.

c. She could use Solver to change her total
expenses by modifying all the cells she
specifies which contain non-essentlal items.

d. She could use the PMT function to calculate
her monthly budget payments and exclude
non-essential items.

Q4. Study the figure below. Continuing from

Casey’s budget pictured above question 3,

what number should be entered in the Value
Of: box figure below?

aniaur .
Ty ool G061 1
Oplimbe e Lo ) Miinvem

O Wnurgn
@ Mive [ ™
[ elwnglng celis GOGHERALABGINE0GT GO 125R31ARE1A m
it poreldion
Cofl anhuraro Qo Unlug
— [I n
— —_— — =
e | e LB
@ |- M
— I'_ ¥ =" —
Wl | =T L w
Qpphune.. [alp Cieno S
a. 3960 b. 10
c. 2850 d. 1

Q5. When you use Solver, there are several
Solving method options you can choose from,
depending on your calculation needs. Which
of the following is NOT an available Solving
Method?

a. Assume varlable as Integer
b. Sum-Product
c. Assume variable as non-negative

d. Limit branch - and - bound depth

Answers o

1. (c) 2. (a) 3. (¢) 4. (c) 5. (b)

Case Study 2

Cell Reference: A cell reference in Calc refers
to the value of a different cell or cell range on the
current worksheet or a different worksheet within
the spreadsheet. A cell reference can be used as a
variable in a formula. The simplest cell reference
appears as a simple mention of the referred cell
after an equal sign. For example (=C5) refers to
the value within cell C5. It means that the value
of the current cell is equal to the value of C5.The

@g www.studentbro.in



objective and constraint cells. Solver adjusts the

values in the decision variable cells to satisfy the

limits on constraint cells and produce the result

you want for the objective cell.

Q L What is GoalSeek?

Q2. Which option displays a cell address in
GoalSeek dialog box?

Q 3. What is the use of solver?

Q 4. How to open solver dialog box.

Q 5. In solver dialog box which option indicates the
formula cell?

Answers *

1 A GoalSeek feature provides a target based
result and informs the user about the changes
in value in the applied formula.

2. A Formula Cell option displays a cell address in
GoalSeek dlalog box.

3. Solver feature of OpenOffice Calc deals with
formulas with multiple unknown value.

4. Click on Tools — Solver

. Target Cell in solver dialog box option Indicates

the formula cell

on

@ Very Short Answer Type Questions N

Q 1. Define OpenOffice Calc.

Ans.

Qa.

Ans.

Q3.
Ans.

Q4.
Ans.

Q5.

Ans.

Q 6.
Ans.

Calc Is the spreadsheet component of OpenOffice.
org (000). We can enter data (usually numerical)
in @ spreadsheet and then manipulate this data to
produce certaln results.

What do you mean by spreadsheet?

An electronic spreadsheet Is an excel sheet made up
of rows and columns. used for calculations.

What is consolidate data?

Consolidate means that to combine a number
of things into a single unit Consolidating of data
means that the process of combining the number
of data organised Into different sheets Into one
warksheet ar cell.

What is the use of Link to source data?

The Link to source data option is used to update
the value in consoldated worksheet formula cell
automatically when the user changes data In source
cell

What is the role of function option in consolidate
dialog box?

The functlon option in consolidate dlalog box allows
to select the function In the destinatlon cells. This Is
the first thing that has been done by the user in the
consolidating data process.

What is the consolidation ranges list?

The consolidation ranges list displays the lst of
selected ranges from where the input Is coming. It
is the ranges of other sheets or input values. It is
displayed like this: SSheetl1.SAS6.
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Q7. What do you mean by Subtotal?

Ans. Subtotal is the sum of a set of numbers, which is
then added to another set of numbers to make the
grand tatal.

Q 8. Explain Var function.

Ans. Var function estimates the variance of a population
on the basls of a sample of numbers.

Q 9. Define Varp function.

Ans. Varp function estimates the varlance of a population
on the basis of an entire population of numbers.

Q 10. Define the following:
(i) Average function (ii) Count function
Ans. (i) Average function: It calculates the average of
numbers.

(ii) Count function: It counts non-empty cells.

Q 11. How Count Numbers function is different from the
Count function?

Ans. Count Numbers function counts the cell that contaln
numbers while the Count function counts non-
empty cells.

Q 12. Explain the term outline.

Ans. Subtotal creates a hierarchy of groups. known as
outline. which lets us display or hide the details
for each subtotal or view just a summary of the
subtotals and ground totals.

Q 13. What is What-If Scenario?

Ans. What-If Scenario is the process of calculating
backwards to find out an input by providing a specific
output It can be considered to be the opposite to
formulae.

Q 14. What do you mean by Solver?

Ans. Solver belongs to a speclal set of commands of
What - if Analysis tools. It's primarily purpose is
simulation and optimisation of various business and
engineering models.

Q 15. Define Objective cell.

Ans. The Objective cell is the cell containing a formula
that represents the ob|ective. or goal. of the problem.
The objective can be to maximise, minimise or
achieve some target value.

Q 16. What is the use of What-if Scenario? How to modify
existing scenarios?

Ans. A What-if Scenario function provides a tool to test
and quickly change the arguments of formula and
view the new results. We can use navigator to
modify existing scenarlos.

Q 17. What is Trace Dependents?

Ans. The Trace Dependents optlon displays the arrow
points to the cells directly dependent on the current
cell
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C Click in an empty space at the end of the lUne
of sheet tabs.

d. All of the methods lsted above are ways of
inserting new sheets into a workbook.
Q 3. Study the screenshot below. How would you
go about deleting the worksheet above named
Address?

28 |RENT 1100
30 [POWER 85
31 \WATER

1e|[ 4> || [ Sheet2 [ Sheet3
Sheet4 /5

c. The formula: SUM(JANUARY.C27:FEBRUARY.
C27:MARCH.C27) will calculate across all
three worksheets.

d. The formula: =SUM(JANUARY. FEBRUARY.
MARCH) will calculate across all three

a. Right-click the warksheet tab named Address
and select Delete sheet from the menu list.

b. Left-click the worksheet tab named Address
and press Delete on your keyboard.

c Left-click and drag the waorksheet tab named
Address out of the Excel window to delete it.

d. All of the options listed above are valid
methods for deleting a worksheet in Excel

Q 4. How do you change the colour of worksheet
tabs?

a. It Is not possible to change the color of
worksheet tabs.

b. Select the worksheet tab by left-clcking it and
then select a barder shading colour from the
Font group under the Home tab.

c Right-click the worksheet tab. go to Tab Color
on the menu list and select a colour.

d. Use the Format Painter in the Clipboard
group under the Home tab to apply colour to
waorksheet tabs.

Q5. Study the screenshot below. Which of the
formulas listed below do you think will
accurately SUM the totals from the January,
February, March worksheets above for each
employee when inserted into the selected cell
in the Salary Totals worksheet?

| 25 AYUSH 20000

26 DEEPAK 24000!

JOHN | 15000'

28 ROHIT 35000

29 ANKUR 34000

30 GAURAV 2?000[

31

1 4 v » \ JANUARY { FEBRUARY (MARCH)TOTAL SALARY
Shoot4 /4

a. The formula: =SUM(JANUARYIC27, FEBRUARYIC27,
MARCHIC27) will calculate across all three
warksheets.

b. The formula: =SUM(JANUARY:C27 FEBRUARY:C27.
MARCH:C27) will calculate across all three
worksheets.
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x>

worksheets.
Answers °
1. (c) 2. (d) 3. (3) 4. (c) 5. (c)
Case Study 4

Running a Macro: A macro, in the context of
computer science, is short for macroinstruction
which is a set of instructions combined into a
single action that can be repeatedly executed.
Macros may seem very intmidating at first
glance, but by working through this tutorial and
practicing in Microsoft Excel, you will be a pro in
no time.

Macros are code that automate work in a
program—they let you add your own tiny features
and enhancements to help you accomplish exactly
what you need to do, quickly with just a click of
a button. In a spreadsheet tool like Calc, macros
can be especially powerful. Hidden behind the
normal user interface, they are more powerful
than standard functions you enter into a cell
(e.g. =1IF(A2<100,100,A2)).

Q 1. Which of the descriptions listed below best

describes what a macro in Excel does?

a. It is a type of formatting you can apply to
enlarge the warksheet area.

b. Itis a file type that you save a workboaok as.

c. It is a series of instructions contained in one
command that you can use to automate
complex and/or repetitive tasks.

d. It Is a recording function that allows you to
save worksheets. audio recordings and videos
that are displayed on the screen.

Q2. Study the screenshot below. What is the
appropriate action to take when a workbook
displays this message (JRE required to perform
this task)?

IE Prguisad X

OpeonOfico roguies a Jies runGog araioiment CRE 1o pofonm G ek Feoe
il o JFE andowdon CGpoeirDifee

a. Close it immediately and delete the file.

b. Check where the file originates from, and if
it is a trusted source or your own workbook.
click ok.

c. Close the file then right-clck and rename it
before opening it agaln.

d. None of the options listed above are correct.
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Q 3. Why Java Runtime Environment (JRE) is required

to perform the task?

3. JRE. Is a software layer that runs on top of
a computer's operating system software
and provides the class libraries and other
resources that a specific Java program needs
to run.

b. Java is required for complete OpenOffice
functionality. Java Is mainly required for
the HSQLDB database engine (used by our
database product Base) and to make use of
accessibility and assistive technologies.

c. Both a. and b.

d. None of the above

Q 4. Study the screenshot below. Where will you
find the option to launch the Macro Selector
dialog?

Wi Deloior b

SO Mo Ly ] noaloig Mo moiayou-nunt THea a1l 15
wainnn wniler “blnsro nnme'.

Ly [leyio nemns

WG Wy Mucu 1 1 | P
i EE QpanOion Mool
il B Canwnl

Lhap

Tt

Data consolidation cnables businesses to
streamline their data resources, discover patterns,
and look for insights in multiple types of data.
Data consolidation refers to the collecuon and
integration of data from multiple sources into a
single destination. During this process, different
data sources are put together, or consolidated,
into a single data store.
Because data comes from a broad range of sources,
consolidation allows organisations to more easily
present data, while also facilitating effective data
analysis. Data consolidation techniques reduce
inefliciencies, like data duplication, costs related
to reliance on multiple databases and multiple
data management points.
Q L What is the use of consolidate feature?
Q2. How to use row labels and column labels
options?
Q3. How to open a consolidated dialog box in

00 Calc?
Q 4. How to create a range in OpenOffice Calc?

Q 5. Name the button which is used to define a
range after typing name?

a. Use Data = Macros > Run Macro to open the
Macro Selector dialog

b. Use Insert = Macros = Run Macro to open the
Macro Selector dlalog

c. Use Tools > Macros = Run Macro to apen the
Macro Selector dialog

d. Use Format = Macros > Run Macro to open
the Macro Selector dlalog
Q 5. In Openoffice.org Calc, macro is saved in..........
a. Warksheet > Library > Module
b. Warksheet > Module
c. Warksheet = Module > Library
d. None of the above
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Answers s
1. (c) 2. (b) 3. (c) 4. (c) 5. (a)

Case Study 5

Data consolidation 1s the corralling, combining,
and storing of varied data in a single place. It
lets users manipulate diftferent types of data from
one point of access and helps turn raw data into
insights that drive better, faster decision-making.
The term sometimes 1s used interchangeably with
data integration.

Answers o

1. The consoldate feature provides the contents

of ane cell from more than one sheet that can
be combined in one place.

2. The row labels and column labels options will
only available when you click on Consolidate by
button.

3. Click on Data — Consolidate option.

4. Insert — Names — Define

5. Add button Is used to define a range after typing
name.

Case Study 6

The Goal Seek Excel function (often referred to
as What-if-Analysis) is a method of solving for
a desired output by changing an assumption that
drives 1. The function essentially uses a trial
and error approach to back-solving the problem
by plugging in guesses untl it arrives at the
answer. For example, 1f the formula for revenue
is equal to the number of units sold multiplied
by the selling price, Goal Seck can determine
how many units have to be sold to reach
$1 million of revenue, if the selling price is known.
The function is extremely useful for performing
sensitivity analysis in financial modeling.

Use Solver to find an optimal (maximum or
minimum) value for a formula in one cell —
called the objective cell -~ subject to constraints,
or limits, on the values of other formula cells on
a worksheet. Solver works with a group of cells,
called decision variables or simply variable cells
that are used in computing the formulas in the
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Q 18.
Ans.

Q 19.
Ans.
Q 20.

Ans.

Q21
Ans.

Q22.

Ans.

Q 23.
Ans.
Q 24.

Ans.

Q 25.
Ans.

Q 26.
Ans.

Q27.
Ans.

Q 28.
Ans.

Define Multiple Operations tool.

A Multiple Operations tool Is used to create a
formula array in OpenOffice (00) Calc.

How many arguments can be altered in GoalSeek?
One arguments can be altered In GoalSeek

Which option is used to type a resultant value to
achieve the goal?

Target Value option Is used to type a resultant value
to achleve the goal.

What is the use of variable cell?

The varlable cell option allows to select a cell to
display or set the result value In a GoalSeek dlalog box.

What option appears when we click on OK button
in GoalSeek dialog box in OpenOffice Calc?

GoalSeek Successful Message box option will appear
when we click an OK button in GoalSeek dlalog box
in OpenOffice Calc

What is the maore elaborate form of GoalSeek?
Solver Is the more elaborate form of GoalSeek.
What is the advantage of sharing worksheet data?

The advantages of sharing worksheet data are as
follows:

(i) Speed up data entry.
(i) Make things easler for collabaration purposes.
What is the purpose of adding comments?

Comments helps reviewer to see or add the changes
done on the worksheet.

How can we add comments to the changes made?
Edit — Changes —» Comments

Why do we need to merge worksheets? [CBSE2023]

Sometimes. multiple reviewers return edited
versions of a worksheet at the same time. In this
case. it may be quicker to review all of these changes
at once, rather than one review at a time. For this
purpose. we need to merge worksheets.

What are Macros?

A Macro Is a saved sequence of commands or
keystrokes that are stored for later use.

*I Short Answer Type Questions N

QL

Ans.
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What are the features provided by Calc?
The various features provided by Calc are as follows:
(i) Functions, which can be used to create formulas
to perform complex calculations on data.

(Ii) Database functions. to amrange. store. and filter data.

(i) Dynamic charts; two new types of charts—
Bubble Charts and Filled Net Charts—have been
introduced in OpenQOffice.org(000) 3.2.

(iv) Macros. for recording and executing repetitive
tasks; scripting languages supported include
OpenOffice.org Baslc. Python. BeanShell and
JavaScript

0§

Ans.

Qa.

Ans.

Q4.

Ans.

Q5.

Ans.

Q6.

Ans.

(v) Ability to open. edit. and save Microsoft Excel
spreadsheets.
(vl) Import and export of spreadsheets in multiple
formats, including HTML, CSV, PDF, and PostScript
Write steps to use consolidating data in OpenOffice
Calc.
Steps to Consolidating Data in OpenOffice Calc
Prepare your worksheets for data consolidation and
follow these steps:
(i) Click on Data — Consolidate option. A
consolidate dlalog box will appear.
(ii) The dialog is almost similar like MS Excel Select
your desired function and add references to the
cells by selecting ranges.

(i) Click on more button to add row labels and
column labels or to link source data.

How to add input value cells without creating
ranges for data consolidation?
To add Input value cells without creating ranges for
data consolidation follow the steps:
Step T: Click on the source data range option.
Step 2: Click on the shrink button.
Step 3: Move to the source worksheet and select the
cell
Step 4: Now again click on the shrink button.
Step 5: Click on the Add button.
Write the options available in the Consolidate
dialog box.
The following options are available in consoldating
the dialog box.

(I) Function

(i) Consolidate Ranges
(iii) Select data range
(Ilv) Copy results to
(v) Labels
(vi) Link to source data
(vii) Button - OK, Cancel Help. Add. Delete. More
What is subtotals in OpenOffice Calc?

Spreadsheet software provides powerful features
to analyse your data. There are some advanced
features that can help to perform some advanced
functions on the formula results. Subtotal is one
of them. Subtotal is used to display your farmula
results according to columns group and row labels.
There are two methods to achieve the same thing in
spreadsheet software.

Subtotal() Formula: The subtotal() formula to group
the results.

Data — Subtotals Command: The graphical command
to do subtotals.

How can we rename a worksheet in Spreadsheet?
There are three ways you can rename a worksheet,
and the only difference between them is the way in
which you start the renaming process. You can do
any of the following;
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Q7.

Ans.

Q 8.
Ans.

Q9.

Ans,

(I) Double-click on one of the existing worksheet
names.

(i) Right-click on an existing worksheet name. then
choose Rename from the resulting Context
menu.

(iii) Select the worksheet you want to rename (click
on the worksheet tab) and then select the Sheet
option from the Format menu. This displays
a submenu from which you should select the
Rename option.

Explain the 1st group tab in short.

The 1st group tab in the first tab of the subtotals

dlalog box It provides 3 optians:

(I) Group By: This option provides on the drop-
down list of column headers used in the
worksheet Select the column name which you
want to display in the subtotals group.

(Il) Calculate Subtotals for: It is used to select the
value to display the result in a group.

(iii) Use Functlons: This option is used to select
different functions Uke sum. count. max. min,
glc.

Define What If scenario with example.
The “What If* scenario feature allows us to create
different target-based “What If* analysis. Suppose
we are playing a cricket tournament where we
need to analyse our team performance on the net
run rate we can use "What If" scenarios. Mareover,
It can help In every match to achleve the target in
different conditions.
These different conditions means:
(i) How many runs are required in how many overs
to qualify an top of the point table?
(i) How many runs need to be saved to climb up in
the point table? etc.
We can create scenarlos with different names and
targets. These scenarios you can view any time
from the scenarios manager.
Distinguish between the following with respect to

spreadsheets: [CBSE 2023]

(i) Relative and Absolute hyperlink.
(ii) Internet hyperlink and Document hyperlink.

(i)

Absolute
Hyperlink

Relative Hyperlink

An absolute
hyperlink is a
hyperlink that
contains the full
address of the
destination file or
of the website.

(a) | A relative hyperlink
is a hyperlink that
contains an address
that is relative to
the address of the
destination file.
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Q 10.
Ans.

Q1L

Ans.

Q12
Ans.

It doesn't waorlk
if the target is

(b) [ It doesn't wark if
the start and target

locations change moved.
relative to each
other.
(il
Internet Hyperlink Document
Hyperlink
(a) | Internet hyperlink | Document

connect content
across the global
network of the
world wide web.

hyperlinks are
used to connect
content within a
specific document
or on a local
network

For a document
hyperlink, specify
the worksheet
path or leave

this blank if you
want to link to a
target in the same
spreadsheet.

(b) | For an internet
hyperlink, choose
the type of
hyperlink either
web, FTP or
Telnet and enter
the required web
address (URL).

Explain features and use of Record changes.
Calc has the feature to track what data was changed
when the change was made. who made the change.
and In which cell the change has occurred. A colored
border, with a dot in the upper left-hand corner,
appears around a cell where changes were made.
Other reviewers then quickly know which cells were
edited. A deleted column or row Is marked by a
heavy-colored bar.
Example: If you are the sponsor of a youth baseball
team. the coach has submitted a budget to you
for the season and you need to edit the costs and
return them to her. You are concerned that if you
just make the changes, then the coach won't see the
changes you made. You declde to use Calc with the
record changes feature turned on so that the coach
can easily see the changes you have made.

What is the purpose of adding comments? How

can we add comments to the changes made?

Reviewers and authors can add their comments to

explain thelr changes.

To add a comment to a change:

(i) Make the change to the spreadsheet

(i) Select the cell with the change.

(iii) Choose Edit > Changes > Comments. The dialog
shown below appears. The automatically-added
comment provided by Calc appears in the title
bar of this dlalog and cannot be edited.

(iv) Type your own comment and click OK.

Explain the feature of accepting or reject changes.

When you receive a worksheet back with changes.

the beauty of the recording changes system
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becomes evident. Now, as the original authaor, you
can step through each change and decide how to
proceed. To begin this process:
(i) Open the edited worksheet.
(ii) Select Edit > Changes > Accept or Reject. The
dialog shown below opens.
(i) Calc steps through the changes one at a time.
You can choose to accept or reject each change
as you go through it.

OR
You can also select Accept all and refect all if you
want to do so.

) Long AnSWer Type Questions N

QL

Define a range for consolidate data in OpenOffice
Calc.

Ans. This optlon Is useful for consoldate data in

OpenOffice Calc. So follow these steps to define a
range In OpenOffice Calc:

(I) Select the cells for which you want to create a
range.

(ii) Click on Insert - Names — Define or press Ctrl
+ F3. A Define Names Dialog box will appear on
the screen.

(iii) Type the range in the Name box Do not use
space in range names.

(iv) The Add button will active click on that.

(v) Click on OK.

Q 2. Write all the steps for creating scenarios.
Ans. To create a scenario, select all the cells that provide

the data for the scenario.
(1) Select the cells that contain the values that will
change between scenarios. To select multiple
cells. hold down the Ctrl key as you click each cell

(i) Choose Tools > Scenarios.

(i) On the Create Scenario dialog, enter a name for
the new scenario. It's best to use a name that
clearly identifies the scenario, not the default
name as shown in the illustration. This name Is
displayed in the Navigator and on the title bar of
the scenario on the sheet itself.

(iv) Optionally add some information to the
Comment box. The example shows the default
comment. This information is displayed in the
Navigator when you click the Scenarios icon and
select the deslred scenarlo.

(v) Optionally select or deselect the options in
the Settings sectlon. See below for more
information about these options.

(vi) Click OK to close the dlalog. The new scenario is
automatically activated.

Q 3. What is merging worksheet feature in OpenOffice

Ans.

Get More Learning Materials Here : &

Calc?
Merging Warksheets: Sometimes. multiple reviewers
return edited versions of a worksheet at the same

Q4.

Ans.

Q5.

Ans.

time. In this case. it may be quicker to review all of
these changes at once. rather than one review at a
time. For this purpose. Calc provides the feature of
merging worksheets.
To merge worksheets, all of the edited worksheets
need to have recorded changes In them.

(i) Open the ariginal worksheet

(i) Select Edit > Changes > Merge Document.

(i) A file selection dialog opens. Select a file you
want to merge and click OK.

(iv) After the worksheets merge, the Accept or
Reject Changes dialog opens. If you want to
merge more warksheets, close the dialog
and then repeat steps 2 and 3. Now all of the
changes are combined Into one worksheet and
you can accept or reject the changes. Changes
from different authors appear in different
colors In the worksheet.

What is meant by Viewing Changes feature In

OpenOffice Calc?

Calc gives us tremendous control over what changes

we see when reviewing a worksheet. To change

the avallable filters. select Edit > Changes > Show.

Using the different settings. you can control which

changes appear an screen. You can filter based on:

(I) Date - Only changes made in a certaln time
range are displayed.

() Author - Only changes made by a specific
author are displayed. This Is especlally useful if
you have multiple reviewers on the worksheet

(ilf) Range - Only changes made In a specific range
of cells are displayed. This s especlally useful if
you have a large spreadsheet and only want to
review a part of it

(iv) Comment: Searches the content of the
comments and only displays changes which
have comments that match the search criterla.

(v) Show accepted changes: Only changes you
accepted are displayed.

(vi) Show rejected changes: Only changes you
rejected are displayed.
Explain the options tab of the subtotals dialog box
in short.
The options tab of the subtotals dialog box has
mainly two options:
(i) Groups (i) Sort
(a) The group's options are applicable to the
group and provide the following options:
» Page break between groups: Display each
group on different pages.
- Case sensitive: Check the case sensitive
data Le. matches upper and lower case text.
» Pre-sort area according to groups: It will
sort the data according to results.
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(b) The sort group option provides sorting
options like ascending or descending order
and custom sort order according to users.

Q 6. Discuss Comparing documents in OpenOffice Calc.

Ans. Comparing Documents: When sharing worksheets
reviewers may forget to record the changes they
make. This Is not a problem with Calc because Calc
can find the changes by comparing worksheets.

In order to compare worksheets you need to have

the ariginal waorksheet and the one that is edited. To

compare them:

(i) Open the edited worksheet that you want to
compare with the original worksheet.

(ii) Select Edit > Compare Document

(i) An open warksheet dlalog appears. Select the
original worksheet and click Insert.

Calc finds and marks the changes as follows:

(I) ALl data that occurs In the edited worksheet but
not in the original Is identified as Inserted.

(i) AWl data that Is in your original worksheet but
is not in the edited warksheet Is Identified as
deleted.

(iii) AUl data that is changed. is marked as changed.

Q 7. What are Macros? How can we record a Macro?
Ans. A macro is a saved sequence of commands or
keystrokes that are stored for later use. An example
of a simple macro is one that “types” your address.

The OpenOffice.org (000) macro language is very

flexible, allowing automation of both simple and

complex tasks.

Using the Macro Recorder: The following steps

create a macro that performs paste speclal with

multiply.

(I) Open a new spreadsheet.

(I) Enter numbers Into a sheet.

(iii) Select cell A3, which contains the number 3.
and copy the value to the clipboard.

(iv) Select the range A1.C3.

(v) Use Tools > Macros > Record Macro to start
the macro recorder. The Record Macro dialog is
displayed with a stop recording button.

(vi) Use Edit > Paste Speclal to open the Paste
Special dialog.

(vii) Set the operation to multiply and click OK. The
cells are now multiplied by 3.

(viil) Clck Stop Recording to stop the macro recarder.
The OpenOffice.org Basic Macros dialog opens.

(ix) Select the current worksheet. For this example,
the current Calc worksheet [s Untitled 1. Existing

worksheets show a library named Standard.
This library Is not created until the warksheet is
saved, ar the Ubrary is needed, so at this point
your new worksheet does not contain a library.
You can create a new Ubrary to contaln the
macro, but this is not necessary.

Get More Learning Materials Here : &

(x) Click New Module. If no Ubrarles exist, then the
Standard Ubrary Is automatically created and
used. In the New Module dlalog, type a name for
the new module or leave the name as Modulel.

(xi) Click OK to create a module named Modulel.
Select the newly created Modulel. enter the
macro name Paste Multiply and click Save.

(xii) The created macro is saved In Modulel of the
Standard Ubrary In the Untitled 1 worksheet.
TP~
Do not try to learn the steps but have a practical outlook
of them so that they can be memorised easily.

x>

Q 8. Let's say you have $10,000 that you want to invest
in two mutual funds for one year. Fund X is a low
risk fund with 8% interest rate and Fund Y is a
higher risk fund with 12% interest rate. How much
money should be invested in each fund to eamn a
total interest of $1000? Find the solution using
Solver feature.

Ans. To find the answer using Solver:
(i) Enter labels and data:

(a) Row labels: Fund X. Fund Y, and total in cells
A2 thru A4,

(b) Column labels: interest earned. amount
Invested. Interest rate. and time period. in
cells B1 thru E1.

(c) Interest rates: 8 and 12. in cells D2 and D3.

(d) Time period: 1. in cells E2 and E3.

(e) Total amount invested: 10000, in cell C4.

(i) Enter an arbitrary value (O or leave blank) in cell

C2 as amount invested in Fund X.

(lif) Enter the formulae glven below:

(a) In cell C3. enter the formula C4-C2 (total
amount - amount invested in Fund X) as the
amount invested in Fund Y.

(b) In cells B2 and B3, enter the formula for
calculating the interest earned (see below).

(c) In cell B4, enter the formula B2+B3 as the
total Interest earned.

Iﬁ Uridad 1 - OpenCitice Cale
Eie Ede Yow [neot Fpwwr Jooln [Dia Window Help

B -B-H m| &R PRE Dl -F -
@ [ - N M BIJIU EEam Jh
B1 v fa E = [eCrOUI00E)
A C [} [
| Inboroal Emmed [Amount lovestod inloeost Reio |Time Porlod
2 |Fumd X 1] g
I“Funﬂ“f 120 10000 12
4 |Tounl 1200 10000

(lv) Choose Tools -> Solver. The solver dlalog opens

as shown in Figure.
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(v) Click in the Target cell field. In the sheet. click
In the cell that contalns the target value. In this
example, it is cell B4 containing total interest
value.

Select Value of and enter 1000 in the field next
to it. In this example. the target cell value Is
1000 because your target is a total interest
earned of S1000. Select Maximum or Minimum
if the target cell value needs to be one of those
extremes.

(vi)

(vil) Click In the By changing cells field and click on
cell C2 In the sheet. In this example. we need to
find the amount invested in Fund X (cell C2).
Enter limiting conditions for the variables by
selecting the Cell reference. Operator and
Value fields. In this example, the amount
invested in Fund X (cell C2) should not be
greater than the total amount available (cell
C4) and should not be less than O.

Click OK. A dialog appears informing you that
the Solving successfully finished. Click Keep

(viil)

Result to enter the result in the cell with the
variable value. The result is shown below.

a Uatitied 1 - OpenOffice Calc
.Eﬂe Edit \eew |nzet Fgrme! Jook [ota Window Hdp
R-B-Hm BER Y K@ -F D~ -]
L@ [ Vo M B/ U E==m |||k
a v k8 = [ua
A | B D E

1 Intorest Enrmnod |[Amount Invested Indocest Roto  Time Parlod
2 Fund X 400 5000 i i
Fund Y B0 G | 12 1

4 _|Total 1000 100001 |

& Chapter Test

Multiple Choice Questions

QL

Q2.

Q3.

In 00 Calc, which options should be used to accept/
reject the changes in the shared sheet?

a. Edit->Accept

b. Edit->Changes->Record

c. Edit->Changes->Shaw

d. Edit-=Changes-Accept/Re|ect

What will do by filter?

a. DIsplays the records that meet the criteria

b. Displays only one record to delete

c. Modify all the records at once

d. All of the above

What is integer value of 3/2+5°0.5+A1 where

A1=0.75

a. 75 h.5 .= d. 6

Q7. In which option we have to specify the target range
(Where we want the result to be displayed)
a. Source data range b. Copy results to

C. Need result at d. Target range

Fill in the Blank Type Questions

Q 8. The first cell in the upper left corner is ............ :
Q9. ...cciieiiieiiniinieena. IS @ feature that’s opposite to undo.
Q 10. By default, the name of the first workbook is.............

Assertion and Reason Type Questions

Q 4. What would be content of A8 if A4 has count
(A1:A7)and ifA1=1,A2=2,A3=4,A11=12 A6=Blank,
A7=Text
a. 7 b. 5 c 17 d. 29

Q 5. We can consolidate data by........cccceeiuenniinnnes
a. row label b. column label
c. Both of these d. None of these

Q 6. Which of the following functions are available in
consolidate window?

a. Max b. Min
c. Count d. All of these

Get More Learning Materials Here : &

Directions (Q. Nos. 11-13): /n the questions given below,
there are two statements marked as Assertion (A) and Reason
(R). Read the statements and choose the correct option.
a. Both Assertion (A) and Reason (R) are true and
Reason (R) Is the correct explanation of Assertion (A).
b. Both Assertion (A) and Reason (R) are true, but
Reason (R) Is not correct explanation of Assertion (A).
c Assertion (A) is true, but Reason (R) is false.
d. Assertlon (A) Is false. but Reasaon (R) Is true.

Q 11. Assertion (A): The Solver option is present in the
data group.
Reason (R): The primary purpose of Solver is
simulation and optimisation of various business
and engineering models.
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Q12.

Q13.

Assertion (A): The product function calculates the
product of cells.

Reason (R): We can use the subtotals feature of
subtotal data in a sorted list.

Assertion (A): We can use What-if-Analysis tools
to estimate our monthly savings that meet our
retirement goals.

Reason (R): The What-if Analysis option is present
in the information tab.

Case Study Based Questions

Q 14.

SUBTOTAL is a function listed under the
Mathematical category when you use the
Function Wizard (Insert > Function). Because
of its usefulness, the function has a graphical
interface accessible from Data > Subtotals. As the
name suggests, SUBTOTAL totals data arranged
in a array—that is, a group of cells with labels
for columns. Using the Subtotals dialog, you can
select up to three arrays, then choose a statistical
function to apply to them. When you click OK,

Calc adds subtotal and grand total rows to the

selected arrays, using the Result and Result2 cell

styles to differentiate those entries. By default,
matching items throughout your array will be
gathered together as a single group above a subtotal.

() Where would you find the Subtotal function?
a. Under the Formula tab.

b. Under the Home tab.

C Under the Insert tab.

d. Under the Data tab.

(ii) Sally impressed her boss by creating an
Outline of data in a worksheet with each section
containing a Subtotal. Her boss wishes to print
each of the 300 sections and their totals on a
separate page. Which of the following options
will succeed in doing this in most EFFICIENT
way?

a. This is a print setting. Set the printer to print
each page on a separate piece of paper.

b. Insert manual page breaks by using the Insert
Page Break function located under the Page
Layout tab an the Ribbon.

C Select the data, launch the Subtotal dialog
box and tick the box for Page Break between
Groups.

d. All of the options listed above are correct.

(11i) To display the sum of values ..
option must be checked in the subtutals dialog
box.

a. calculate subtotals for

b. calculate subtotals all

¢. calculate subtotals from
d. All of the above

Get More Learning Materials Here : &

(iv) What are the different tabs available in the

subtotals dialog box?

a. 1st Group b. 2nd Group

C. 3rd Group d. All of these
(v) What are the common functions available in

subtotal dialog box?

a. Sum b. Average

c. Count d. All of these

Q15. Sometumes, we need data based on different

categories. SUBTOTALS help us to get the totals
of several columns of data broken down into
various categories. For example, let's consider
garment products of different sizes manufactured.
The SUBTOTAL function will help you to get a
count of different sizes in your warehouse.
The SUBTOTAL function in Excel allows
users to create groups and then perform various
other Excel functions such as SUM, COUNT,
AVERAGE, PRODUCT, MAX, etc. Thus, the
SUBTOTAL function in Excel helps in analysing

the data provided.
(i) What is the use of subtotals feature?

(ii) How to open subtotals feature in OpenOffice
calc?

(ili) Name some parts of subtotals tab.

(iv) Which option pops up a drop-down list which
contains columns to group by for subtotals?

(v) How to see the different levels of subtotals?

Very Short Answer Type Questions

Q 16. Which option allows to select the source of data for
the consolidation?

Q17. Explain Variable cell.

Q 18. What are the common functions available in
Subtotal dialog box?

Q 19. Answer the following questions:
(i) How to open navigator window?
(ii)) What is a shortcut key to open navigator window?

Q 20. What is the use of shrink button?

Q 21. How to open GoalSeek dialog box?

Short Answer Type Questions

Q 22. What options are available in create Scenario dialog
box?
Q 23. Differentiate between relative and absolute hyperlinks.

Long Answer Type Questions

Q 24. Write steps to create or apply subtotals in a worksheet.

Q 25. What are the several situations that can occur when
we save a shared document?
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